Internet Explorer and Microsoft Edge module issues
Incident Report for JobTeaser
Resolved
This issue has now been resolved.

Thanks for your patience
Posted Mar 10, 2020 - 13:34 CET
Identified
The issue has been identified and a fix is now being implemented.
Posted Mar 10, 2020 - 11:39 CET
Investigating
Dear Users,

We are currently experiencing an issue with various modules of the platform, on Internet Explorer and Microsoft Edge browsers.

We're still investigating the cause and will provide an update as soon as possible.
We do however have a workaround for the meantime. If you’re facing this problem, please try to use a different browser. We recommend Google Chrome.

Thanks for your patience,

JobTeaser Support
Posted Mar 10, 2020 - 10:37 CET
This incident affected: Students & Alumni Career Center (Dashboard, Companies, Jobs, Events, Knowledge Center) and Company Administration (Shortlist).