Statistics within the application are down.
Incident Report for JobTeaser
Resolved
We release our brand new statistic module, available in French and in English.
New languages are coming soon.
Do not hesitate to share your inputs with us on it directly within the application.

Thank you for your patience.

The JobTeaser Team
Posted Mar 16, 2020 - 18:18 CET
Investigating
Dear Users,

We are currently experiencing an issue with the statistics within JobTeaser.
No data is shown within the interface.

We're still investigating the cause and will provide an update as soon as possible.

Thanks for your patience,

JobTeaser Support
Posted Mar 02, 2020 - 10:47 CET
This incident affected: School & University Administration (Events, Jobs, Statistics) and Company Administration (Jobs, Statistics).