JobTeaser is currently down
Incident Report for JobTeaser
Resolved
This incident has been resolved.
Posted Sep 17, 2019 - 11:23 CEST
Investigating
Dear Users,

JobTeaser is currently down. Our Tech Team is currently investigating the issue with the highest priority.

Thank you for understanding.
Posted Sep 17, 2019 - 11:20 CEST
This incident affected: Login & SSO (Sign in, Sign up), Students & Alumni Career Center (Dashboard, Companies, Jobs, Métiers (Available only on the French version), Advice, Events, Knowledge Center, Appointments), School & University Administration (Events, Jobs, Companies, Knowledge Center, Talent Banks, Statistics, Users, Appointment System, Help Center), Company Administration (Account, Events, Jobs, Talent Banks, Statistics), and Mail Delivery System.