Platform is down

Incident Report for JobTeaser

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 11:03 CET

Update

The situation should now be solved and no further issues should be encountered, however we will keep monitoring the platform for the remainder of the day.
Posted Mar 03, 2026 - 12:55 CET

Update

We are continuing to monitor the situation, nevertheless a maintenance will be performed at 12:45 UTC+1 today for a duration of ca. 5 minutes. During the maintenance the entire website may be unreachable.
Posted Mar 03, 2026 - 11:37 CET

Monitoring

An action has been undertaken to restore proper functioning. The platform remains under observation to monitor the resolution. In the meantime additional, short outages could still happen.
Posted Mar 03, 2026 - 10:42 CET

Investigating

We are currently investigating this issue.
Posted Mar 03, 2026 - 10:35 CET
This incident affected: Career Center, Corporate.jobteaser.com, and Learning.jobteaser.com.