A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2025 - 12:18 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 25, 2025 - 12:17 CET
Investigating
We are currently investigating an issue causing the JobTeaser platform and its services to be unavailable.
Posted Nov 25, 2025 - 12:11 CET
This incident affected: Career Center, Job-Alert, Insights, Guidance tools, Event, Email Campaign, Corporate.jobteaser.com, Company Pages, Appointments, Infrastructure, Job-Ad, Resources, Learning.jobteaser.com, Shortlist, Statistics, Talent Bank, Tracking, Help Center, and User.