Unable to create an appointment when selecting advisor

Incident Report for JobTeaser

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 12:10 CET

Investigating

We are currently investigating an issue affecting the creation of appointments when selecting a specific advisor.
Posted Nov 26, 2025 - 11:39 CET
This incident affected: Appointments.