JobTeaser platform outages

Incident Report for JobTeaser

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 10:19 CET

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 17:25 CET

Update

The core platform is now accessible. A workaround is in place following the third-party incident. However, some features, like the jobs posting, might not work as expected until the external provider is fully resolved. We are monitoring their progress.
Posted Nov 18, 2025 - 16:25 CET

Monitoring

The core platform is now accessible. A workaround is in place following the third-party incident. However, some features, like the jobs posting, remain unavailable until the external provider is fully resolved. We are monitoring their progress.
Posted Nov 18, 2025 - 15:43 CET

Identified

The JobTeaser platform remains unavailable. The issue has been identified and originates from a third-party provider. We are monitoring their remediation efforts and will update the incident status accordingly.
Posted Nov 18, 2025 - 12:51 CET

Investigating

The JobTeaser platform is experiencing an outage, and access remains unavailable while the issue is being investigated.
Posted Nov 18, 2025 - 12:37 CET
This incident affected: Career Center, Job-Alert, Insights, Guidance tools, Event, Email Campaign, Corporate.jobteaser.com, Company Pages, Appointments, Infrastructure, Job-Ad, Resources, Learning.jobteaser.com, Shortlist, Statistics, Talent Bank, Tracking, and User.