Email Campaigns Module Unavailable Due to Internal Issue

Incident Report for JobTeaser

Resolved

The matter has been resolved and the Email Campaigns Module is back to be fully functional.
Posted Oct 21, 2025 - 14:49 CEST

Identified

An issue has temporarily made the Email Campaigns Module unavailable. At this time, it is not possible to create or send new email campaigns. We are actively working with the third-party service provider to resolve the issue and restore functionality as soon as possible. Thank you for your patience.
Posted Oct 21, 2025 - 11:00 CEST
This incident affected: Email Campaign.