The temporary talent banks are currently not available
Incident Report for JobTeaser
Resolved
This incident has been resolved.
Posted Nov 12, 2019 - 19:10 CET
Monitoring
Dear Users,

We are experiencing an issue with the temporary talent banks as admins from schools and companies get an error 500 when clicking on it.

The Team is currently monitoring the issue.

We will keep you posted.
Posted Nov 12, 2019 - 18:41 CET
This incident affected: Company Administration (Talent Banks) and School & University Administration (Talent Banks).