Cannot save programme information

Incident Report for JobTeaser

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 11:53 CET

Investigating

We are currently investigating an issue that's preventing the user from saving programme related information.
Posted Feb 23, 2026 - 10:58 CET
This incident affected: Career Center.