Corporate website is not accessible
Incident Report for JobTeaser
Resolved
This incident has been resolved. Our corporate website https://corporate.jobteaser.com/ is now accessible again.
Posted Jan 27, 2020 - 11:37 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 27, 2020 - 11:34 CET
Identified
Dear Users,

The website dedicated to our partners (https://corporate.jobteaser.com) is currently not accessible. We have identified the issue and are working on a fix.

Thanks for your patience,

JobTeaser Support
Posted Jan 27, 2020 - 11:11 CET